Archive

Archive for the ‘IoT’ Category

Resolving Amazon Echo registration error 10:2:5:60:1

January 29, 2017 Leave a comment

When trying to register a new “Amazon Echo” into my home network, I received the following error:

There was an error registering your device.  Visit Help for troubleshooting tips.  Error 10:2:5:60:1

I followed all of the usual steps (reset device, reset router, uninstall/reinstall mobile app, etc.), but nothing worked. I also setup a second Wi-Fi network to see if that was the issue.

I should point out that I already had another working Amazon Echo Dot device that was previously setup and still working on the same WiFi network that didn’t have any issues registering. I also took that offline to ensure that wasn’t an issue.

I then removed all other WiFi devices from the network.  It still didn’t work.

I called Amazon support. They were great, but it still didn’t work.  So they sent me a new one and received it in two days.  They’re awesome.

What wasn’t awesome was that the new device had the SAME ERROR!  So now I know it IS the network.

What I found was that with all devices off of the network, I check the logs (Advanced > Logs) on my Cable Modem device (Netgear c6300, Firmware V2.01.14) that I saw that the device was reporting a DoS attack that were coming from the Echo device.  Below is the error I saw:

[DoS attack] Port Scan PROTO:UDP SPT:50395 DPT:123

The firewall didn’t have any restrictions on the devices that could be on the network, nor blocking outbound traffic, so this was weird.  I found a setting to ignore this type of traffic and not block it.  I crossed my fingers and gave it a try.

First, login to your device (typically http://192.168.0.1/ ), then click on the “Advanced” tab.  Click “Setup” in the left menu, then click on “WAN Setup”.  Enable the Checkbox for, “Disable Port Scan and DoS Protection”, then click “Apply”.

Once your device has reset, then go through the normal setup process using Amazon Echo.  Now your Echo should be working.  After it’s working, go back into your Netgear setting and disable the setting we applied earlier.  Afterward, the Echo should still work AND you’re protected from Port Scan and DoS protection.

I hope this helps you in your situation.

Categories: Amazon Alexa, IoT, Technology